What’s Vulnerable › Vulnerabilities
CVE-2021-45624
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
- Weakness: CWE-77
Description
Certain NETGEAR devices are affected by command injection by an unauthenticated attacker. This affects D7000v2 before 1.0.0.66, D8500 before 1.0.3.58, R7000 before 1.0.11.110, R7100LG before 1.0.0.72, R7900 before 1.0.4.30, R8000 before 1.0.4.62, XR300 before 1.0.3.56, R7000P before 1.3.2.132, R8500 before 1.0.2.144, R6900P before 1.3.2.132, and R8300 before 1.0.2.144.
Affected products
- NETGEAR D7000V2 Firmware: before 1.0.0.66 — fixed in 1.0.0.66
- NETGEAR D8500 Firmware: before 1.0.3.58 — fixed in 1.0.3.58
- NETGEAR R6900P Firmware: before 1.3.2.132 — fixed in 1.3.2.132
- NETGEAR R7000: before 1.0.11.110 — fixed in 1.0.11.110
- NETGEAR R7000P: before 1.3.2.132 — fixed in 1.3.2.132
- NETGEAR R7100Lg Firmware: before 1.0.0.72 — fixed in 1.0.0.72
- NETGEAR R7900 Firmware: before 1.0.4.30 — fixed in 1.0.4.30
- NETGEAR R8000 Firmware: before 1.0.4.62 — fixed in 1.0.4.62
- NETGEAR R8300 Firmware: before 1.0.2.144 — fixed in 1.0.2.144
- NETGEAR R8500 Firmware: before 1.0.2.144 — fixed in 1.0.2.144
- NETGEAR Xr300 Firmware: before 1.0.3.56 — fixed in 1.0.3.56
How to fix
Upgrade to a fixed version: NETGEAR D7000V2 Firmware 1.0.0.66; NETGEAR D8500 Firmware 1.0.3.58; NETGEAR R6900P Firmware 1.3.2.132; NETGEAR R7000 1.0.11.110; NETGEAR R7000P 1.3.2.132; NETGEAR R7100Lg Firmware 1.0.0.72; NETGEAR R7900 Firmware 1.0.4.30; NETGEAR R8000 Firmware 1.0.4.62; NETGEAR R8300 Firmware 1.0.2.144; NETGEAR R8500 Firmware 1.0.2.144; NETGEAR Xr300 Firmware 1.0.3.56. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064485/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Routers-PSV-2020-0298
- https://kb.netgear.com/000064485/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Routers-PSV-2020-0298
Get alerted when CVE-2021-45624 or the next vulnerability affects your stack