What’s Vulnerable › Vulnerabilities
CVE-2021-45625
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
- Weakness: CWE-77
Description
Certain NETGEAR devices are affected by command injection by an unauthenticated attacker. This affects XR300 before 1.0.3.68, R7000P before 1.3.3.140, and R6900P before 1.3.3.140.
Affected products
- NETGEAR R6900P Firmware: before 1.3.3.140 — fixed in 1.3.3.140
- NETGEAR R7000P: before 1.3.3.140 — fixed in 1.3.3.140
- NETGEAR Xr300 Firmware: before 1.0.3.68 — fixed in 1.0.3.68
How to fix
Upgrade to a fixed version: NETGEAR R6900P Firmware 1.3.3.140; NETGEAR R7000P 1.3.3.140; NETGEAR Xr300 Firmware 1.0.3.68. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064489/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Routers-PSV-2020-0371
- https://kb.netgear.com/000064489/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Routers-PSV-2020-0371
Get alerted when CVE-2021-45625 or the next vulnerability affects your stack