What’s Vulnerable › Vulnerabilities
CVE-2021-45637
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects R6260 before 1.1.0.76, R6800 before 1.2.0.62, R6700v2 before 1.2.0.62, R6900v2 before 1.2.0.62, R7450 before 1.2.0.62, AC2100 before 1.2.0.62, AC2400 before 1.2.0.62, and AC2600 before 1.2.0.62.
Affected products
- NETGEAR Ac2100 Firmware: before 1.2.0.62 — fixed in 1.2.0.62
- NETGEAR Ac2400 Firmware: before 1.2.0.62 — fixed in 1.2.0.62
- NETGEAR Ac2600 Firmware: before 1.2.0.62 — fixed in 1.2.0.62
- NETGEAR R6260: before 1.1.0.76 — fixed in 1.1.0.76
- NETGEAR R6700V2 Firmware: before 1.2.0.62 — fixed in 1.2.0.62
- NETGEAR R6800 Firmware: before 1.2.0.62 — fixed in 1.2.0.62
- NETGEAR R6900V2 Firmware: before 1.2.0.62 — fixed in 1.2.0.62
- NETGEAR R7450 Firmware: before 1.2.0.62 — fixed in 1.2.0.62
How to fix
Upgrade to a fixed version: NETGEAR Ac2100 Firmware 1.2.0.62; NETGEAR Ac2400 Firmware 1.2.0.62; NETGEAR Ac2600 Firmware 1.2.0.62; NETGEAR R6260 1.1.0.76; NETGEAR R6700V2 Firmware 1.2.0.62; NETGEAR R6800 Firmware 1.2.0.62; NETGEAR R6900V2 Firmware 1.2.0.62; NETGEAR R7450 Firmware 1.2.0.62. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064059/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-Some-Routers-PSV-2019-0081
- https://kb.netgear.com/000064059/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-Some-Routers-PSV-2019-0081
Get alerted when CVE-2021-45637 or the next vulnerability affects your stack