What’s Vulnerable › Vulnerabilities

CVE-2021-45638

Description

Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects D6220 before 1.0.0.68, D6400 before 1.0.0.102, D7000v2 before 1.0.0.74, D8500 before 1.0.3.60, DC112A before 1.0.0.56, R6300v2 before 1.0.4.50, R6400 before 1.0.1.68, R7000 before 1.0.11.116, R7100LG before 1.0.0.70, RBS40V before 2.6.2.8, RBW30 before 2.6.2.2, RS400 before 1.5.1.80, R7000P before 1.3.2.132, and R6900P before 1.3.2.132.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D6220 Firmware 1.0.0.68; Netgear D6400 1.0.0.102; NETGEAR D7000V2 Firmware 1.0.0.74; NETGEAR D8500 Firmware 1.0.3.60; NETGEAR Dc112A Firmware 1.0.0.56; NETGEAR R6300V2 Firmware 1.0.4.50; NETGEAR R6400 Firmware 1.0.1.68; NETGEAR R6900P Firmware 1.3.2.132; NETGEAR R7000 1.0.11.116; NETGEAR R7000P 1.3.2.132; NETGEAR R7100Lg Firmware 1.0.0.70; NETGEAR Rbs40V Firmware 2.6.2.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-45638 or the next vulnerability affects your stack