What’s Vulnerable › Vulnerabilities
CVE-2021-45640
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
Description
Certain NETGEAR devices are affected by incorrect configuration of security settings. This affects D3600 before 1.0.0.72, D6000 before 1.0.0.72, D6200 before 1.1.00.34, D6220 before 1.0.0.52, D6400 before 1.0.0.86, D7000 before 1.0.1.74, D7000v2 before 1.0.0.53, D7800 before 1.0.1.56, D8500 before 1.0.3.44, DC112A before 1.0.0.42, DGN2200v4 before 1.0.0.110, DGND2200Bv4 before 1.0.0.109, DM200 before 1.0.0.61, EX3700 before 1.0.0.76, EX3800 before 1.0.0.76, EX6120 before 1.0.0.46, EX6130 before 1.0.0.28, EX7000 before 1.0.1.78, PR2000 before 1.0.0.28, R6220 before 1.1.0.100, R6230 before 1.1.0.100, R6250 before 1.0.4.34, R6300v2 before 1.0.4.34, R6400 before 1.0.1.46, R6400v2 before 1.0.2.66, R6700 before 1.0.2.6, R6700v3 before 1.0.2.66, R6900 before 1.0.2.6, R7000 before 1.0.9.34, R7100LG before 1.0.0.50, R7500v2 before 1.0.3.40, R7900P before 1.4.1.50, R8000P before 1.4.1.50, R8900 before 1.0.4.12, R9000 before 1.0.4.12, RBK20 before 2.3.0.28, RBK40 before 2.3.0.28, RBK50 before 2.3.0.32, RBR20 before 2.3.0.28, RBR40 before 2.3.0.28, RBR50 before 2.3.0.32, RBS20 before 2.3.0.28, RBS40 before 2.3.0.28, RBS50 before 2.3.0.32, WN3000RPv2 before 1.0.0.78, WNDR3400v3 before 1.0.1.24, WNR2000v5 before 1.0.0.70, WNR2020 before 1.1.0.62, WNR3500Lv2 before 1.2.0.62, XR450 before 2.3.2.56, and XR500 before 2.3.2.56.
Affected products
- NETGEAR D3600 Firmware: before 1.0.0.72 — fixed in 1.0.0.72
- NETGEAR D6000 Firmware: before 1.0.0.72 — fixed in 1.0.0.72
- NETGEAR D6200 Firmware: before 1.1.00.34 — fixed in 1.1.00.34
- NETGEAR D6220 Firmware: before 1.0.0.52 — fixed in 1.0.0.52
- Netgear D6400: before 1.0.0.86 — fixed in 1.0.0.86
- NETGEAR D7000 Firmware: before 1.0.1.74 — fixed in 1.0.1.74
- NETGEAR D7000V2 Firmware: before 1.0.0.53 — fixed in 1.0.0.53
- NETGEAR D7800 Firmware: before 1.0.1.56 — fixed in 1.0.1.56
- NETGEAR D8500 Firmware: before 1.0.3.44 — fixed in 1.0.3.44
- NETGEAR Dc112A Firmware: before 1.0.0.42 — fixed in 1.0.0.42
- NETGEAR Dgn2200Bv4 Firmware: before 1.0.0.109 — fixed in 1.0.0.109
- NETGEAR Dgn2200V4 Firmware: before 1.0.0.110 — fixed in 1.0.0.110
- NETGEAR Dm200 Firmware: before 1.0.0.61 — fixed in 1.0.0.61
- NETGEAR EX3700: before 1.0.0.76 — fixed in 1.0.0.76
- NETGEAR Ex3800 Firmware: before 1.0.0.76 — fixed in 1.0.0.76
- NETGEAR EX6120: before 1.0.0.46 — fixed in 1.0.0.46
- NETGEAR Ex6130 Firmware: before 1.0.0.28 — fixed in 1.0.0.28
- NETGEAR Ex7000 Firmware: before 1.0.1.78 — fixed in 1.0.1.78
- NETGEAR Pr2000 Firmware: before 1.0.0.28 — fixed in 1.0.0.28
- NETGEAR R6220 Firmware: before 1.1.0.100 — fixed in 1.1.0.100
- NETGEAR R6230 Firmware: before 1.1.0.100 — fixed in 1.1.0.100
- NETGEAR R6250 Firmware: before 1.0.4.34 — fixed in 1.0.4.34
- NETGEAR R6300V2 Firmware: before 1.0.4.34 — fixed in 1.0.4.34
- NETGEAR R6400 Firmware: before 1.0.1.46 — fixed in 1.0.1.46
- NETGEAR R6400V2 Firmware: before 1.0.2.66 — fixed in 1.0.2.66
- NETGEAR R6700: before 1.0.2.6 — fixed in 1.0.2.6
- NETGEAR R6700V3 Firmware: before 1.0.2.66 — fixed in 1.0.2.66
- NETGEAR R6900 Firmware: before 1.0.2.6 — fixed in 1.0.2.6
- NETGEAR R7000: before 1.0.9.34 — fixed in 1.0.9.34
- NETGEAR R7100Lg Firmware: before 1.0.0.50 — fixed in 1.0.0.50
How to fix
Upgrade to a fixed version: NETGEAR D3600 Firmware 1.0.0.72; NETGEAR D6000 Firmware 1.0.0.72; NETGEAR D6200 Firmware 1.1.00.34; NETGEAR D6220 Firmware 1.0.0.52; Netgear D6400 1.0.0.86; NETGEAR D7000 Firmware 1.0.1.74; NETGEAR D7000V2 Firmware 1.0.0.53; NETGEAR D7800 Firmware 1.0.1.56; NETGEAR D8500 Firmware 1.0.3.44; NETGEAR Dc112A Firmware 1.0.0.42; NETGEAR Dgn2200Bv4 Firmware 1.0.0.109; NETGEAR Dgn2200V4 Firmware 1.0.0.110. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064045/Security-Advisory-for-Security-Misconfiguration-on-Some-Routers-Extenders-and-WiFi-Systems-PSV-2018-0228
- https://kb.netgear.com/000064045/Security-Advisory-for-Security-Misconfiguration-on-Some-Routers-Extenders-and-WiFi-Systems-PSV-2018-0228
Get alerted when CVE-2021-45640 or the next vulnerability affects your stack