What’s Vulnerable › Vulnerabilities

CVE-2021-45658

Description

Certain NETGEAR devices are affected by server-side injection. This affects D7800 before 1.0.1.58, DM200 before 1.0.0.66, EX2700 before 1.0.1.56, EX6150v2 before 1.0.1.86, EX6100v2 before 1.0.1.86, EX6200v2 before 1.0.1.78, EX6250 before 1.0.0.110, EX6410 before 1.0.0.110, EX6420 before 1.0.0.110, EX6400v2 before 1.0.0.110, EX7300 before 1.0.2.144, EX6400 before 1.0.2.144, EX7320 before 1.0.0.110, EX7300v2 before 1.0.0.110, R7500v2 before 1.0.3.48, R7800 before 1.0.2.68, R8900 before 1.0.5.2, R9000 before 1.0.5.2, RAX120 before 1.0.1.90, RBK40 before 2.5.1.16, RBK20 before 2.5.1.16, RBR20 before 2.5.1.16, RBS20 before 2.5.1.16, RBK50 before 2.5.1.16, RBR50 before 2.5.1.16, RBS50 before 2.5.1.16, RBS50Y before 2.6.1.40, WN3000RPv2 before 1.0.0.78, WN3000RPv3 before 1.0.2.80, WNR2000v5 before 1.0.0.72, XR500 before 2.3.2.56, and XR700 before 1.0.1.20.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D7800 Firmware 1.0.1.58; NETGEAR Dm200 Firmware 1.0.0.66; NETGEAR Ex2700 Firmware 1.0.1.56; NETGEAR Ex6100V2 Firmware 1.0.1.86; NETGEAR Ex6150V2 Firmware 1.0.1.86; NETGEAR Ex6200V2 Firmware 1.0.1.78; NETGEAR Ex6250 Firmware 1.0.0.110; NETGEAR Ex6400 Firmware 1.0.2.144; NETGEAR Ex6400V2 Firmware 1.0.0.110; NETGEAR Ex6410 Firmware 1.0.0.110; NETGEAR Ex6420 Firmware 1.0.0.110; NETGEAR Ex7300 Firmware 1.0.2.144. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-45658 or the next vulnerability affects your stack