What’s Vulnerable › Vulnerabilities
CVE-2021-45677
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Certain NETGEAR devices are affected by stored XSS. This affects GS108Tv2 before 5.4.2.36 and GS110TPv2 before 5.4.2.36.
Affected products
- NETGEAR Gs108T Firmware: before 5.4.2.36 — fixed in 5.4.2.36
- NETGEAR Gs110Tp Firmware: before 5.4.2.36 — fixed in 5.4.2.36
How to fix
Upgrade to a fixed version: NETGEAR Gs108T Firmware 5.4.2.36; NETGEAR Gs110Tp Firmware 5.4.2.36. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064448/Security-Advisory-for-Stored-Cross-Site-Scripting-on-Some-Smart-Managed-Pro-Switches-PSV-2019-0191
- https://kb.netgear.com/000064448/Security-Advisory-for-Stored-Cross-Site-Scripting-on-Some-Smart-Managed-Pro-Switches-PSV-2019-0191
Get alerted when CVE-2021-45677 or the next vulnerability affects your stack