What’s Vulnerable › Vulnerabilities
CVE-2021-45679
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
Description
Certain NETGEAR devices are affected by privilege escalation. This affects R6900P before 1.3.3.140, R7000 before 1.0.11.126, R7000P before 1.3.3.140, and RS400 before 1.5.1.80.
Affected products
- NETGEAR R6900P Firmware: before 1.3.3.140 — fixed in 1.3.3.140
- NETGEAR R7000: before 1.0.11.126 — fixed in 1.0.11.126
- NETGEAR R7000P: before 1.3.3.140 — fixed in 1.3.3.140
- NETGEAR Rs400 Firmware: before 1.5.1.80 — fixed in 1.5.1.80
How to fix
Upgrade to a fixed version: NETGEAR R6900P Firmware 1.3.3.140; NETGEAR R7000 1.0.11.126; NETGEAR R7000P 1.3.3.140; NETGEAR Rs400 Firmware 1.5.1.80. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064528/Security-Advisory-for-Vertical-Privilege-Escalation-on-Some-Routers-PSV-2021-0043
- https://kb.netgear.com/000064528/Security-Advisory-for-Vertical-Privilege-Escalation-on-Some-Routers-PSV-2021-0043
Get alerted when CVE-2021-45679 or the next vulnerability affects your stack