What’s Vulnerable › Vulnerabilities
CVE-2021-45680
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-27 · updated 2026-06-17
- Weakness: CWE-787
Description
An issue was discovered in the vec-const crate before 2.0.0 for Rust. It tries to construct a Vec from a pointer to a const slice, leading to memory corruption.
Affected products
- Vec-Const Project Vec-Const: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Vec-Const Project Vec-Const 2.0.0. Check the vendor advisory for mitigations.
References
- https://raw.githubusercontent.com/rustsec/advisory-db/main/crates/vec-const/RUSTSEC-2021-0082.md
- https://rustsec.org/advisories/RUSTSEC-2021-0082.html
- https://raw.githubusercontent.com/rustsec/advisory-db/main/crates/vec-const/RUSTSEC-2021-0082.md
- https://rustsec.org/advisories/RUSTSEC-2021-0082.html
Get alerted when CVE-2021-45680 or the next vulnerability affects your stack