What’s Vulnerable › Vulnerabilities
CVE-2021-45702
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-27 · updated 2026-06-17
- Weakness: CWE-416
Description
An issue was discovered in the tremor-script crate before 0.11.6 for Rust. A merge operation may result in a use-after-free.
Affected products
- Linuxfoundation Tremor-Script: from 0.7.2 before 0.11.6 — fixed in 0.11.6
How to fix
Upgrade to a fixed version: Linuxfoundation Tremor-Script 0.11.6. Check the vendor advisory for mitigations.
References
- https://raw.githubusercontent.com/rustsec/advisory-db/main/crates/tremor-script/RUSTSEC-2021-0111.md
- https://rustsec.org/advisories/RUSTSEC-2021-0111.html
- https://raw.githubusercontent.com/rustsec/advisory-db/main/crates/tremor-script/RUSTSEC-2021-0111.md
- https://rustsec.org/advisories/RUSTSEC-2021-0111.html
Get alerted when CVE-2021-45702 or the next vulnerability affects your stack