What’s Vulnerable › Vulnerabilities
CVE-2021-45809
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-22 · updated 2026-06-17
Description
GlobalProtect-openconnect versions prior to 1.4.3 are affected by incorrect access control in GPService through DBUS, GUI Application. The way GlobalProtect-Openconnect is set up enables arbitrary users to execute commands as root by submitting the `--script=<script>` parameter.
Affected products
- Globalprotect-Openconnect Project Globalprotect-Openconnect: before 1.4.3 — fixed in 1.4.3
How to fix
Upgrade to a fixed version: Globalprotect-Openconnect Project Globalprotect-Openconnect 1.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/yuezk/GlobalProtect-openconnect/issues/113
- https://github.com/yuezk/GlobalProtect-openconnect/issues/113
Get alerted when CVE-2021-45809 or the next vulnerability affects your stack