What’s Vulnerable › Vulnerabilities
CVE-2021-45890
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-27 · updated 2026-06-17
- Weakness: CWE-287
Description
basic/BasicAuthProvider.java in AuthGuard before 0.9.0 allows authentication via an inactive identifier.
Affected products
- Authguard Project Authguard: before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: Authguard Project Authguard 0.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/AuthGuard/AuthGuard/commit/9783b1143da6576028de23e15a1f198b1f937b82
- https://github.com/AuthGuard/AuthGuard/compare/v0.8.0...v0.9.0
- https://github.com/AuthGuard/AuthGuard/issues/166
- https://github.com/AuthGuard/AuthGuard/pull/181
- https://github.com/AuthGuard/AuthGuard/commit/9783b1143da6576028de23e15a1f198b1f937b82
- https://github.com/AuthGuard/AuthGuard/compare/v0.8.0...v0.9.0
- https://github.com/AuthGuard/AuthGuard/issues/166
- https://github.com/AuthGuard/AuthGuard/pull/181
Get alerted when CVE-2021-45890 or the next vulnerability affects your stack