What’s Vulnerable › Vulnerabilities
CVE-2021-45928
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-01 · updated 2026-06-17
- Weakness: CWE-787
Description
libjxl b02d6b9, as used in libvips 8.11 through 8.11.2 and other products, has an out-of-bounds write in jxl::ModularFrameDecoder::DecodeGroup (called from jxl::FrameDecoder::ProcessACGroup and jxl::ThreadPool::RunCallState<jxl::FrameDecoder::ProcessSections).
Affected products
- libjxl: before 0.6.1 — fixed in 0.6.1
How to fix
Upgrade to a fixed version: libjxl 0.6.1. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=36456
- https://github.com/google/oss-fuzz-vulns/blob/main/vulns/libvips/OSV-2021-1055.yaml
- https://github.com/libjxl/libjxl/compare/v0.5...v0.6
- https://github.com/libjxl/libjxl/issues/360
- https://github.com/libjxl/libjxl/pull/365
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=36456
- https://github.com/google/oss-fuzz-vulns/blob/main/vulns/libvips/OSV-2021-1055.yaml
- https://github.com/libjxl/libjxl/compare/v0.5...v0.6
- https://github.com/libjxl/libjxl/issues/360
- https://github.com/libjxl/libjxl/pull/365
Get alerted when CVE-2021-45928 or the next vulnerability affects your stack