What’s Vulnerable › Vulnerabilities
CVE-2021-45979
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-04 · updated 2026-06-17
- Weakness: CWE-78
Description
Foxit PDF Reader and PDF Editor before 11.1 on macOS allow remote attackers to execute arbitrary code via app.launchURL in the JavaScript API.
Affected products
- Foxit PDF Reader: before 11.1 — fixed in 11.1
- Foxit Pdf Reader: before 11.1 — fixed in 11.1
How to fix
Upgrade to a fixed version: Foxit PDF Reader 11.1; Foxit Pdf Reader 11.1. Check the vendor advisory for mitigations.
References
- https://github.com/dlehgus1023
- https://github.com/dlehgus1023/CVE/tree/master/CVE-2021-45979
- https://www.foxit.com/support/security-bulletins.html
- https://github.com/dlehgus1023
- https://github.com/dlehgus1023/CVE/tree/master/CVE-2021-45979
- https://www.foxit.com/support/security-bulletins.html
Get alerted when CVE-2021-45979 or the next vulnerability affects your stack