What’s Vulnerable › Vulnerabilities
CVE-2021-46146
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-10 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in MediaWiki before 1.35.5, 1.36.x before 1.36.3, and 1.37.x before 1.37.1. The WikibaseMediaInfo component is vulnerable to XSS via the caption fields for a given media file.
Affected products
- Wikimedia Foundation MediaWiki: before 1.35.5; from 1.36.0 before 1.36.3; from 1.37.0 before 1.37.1 — fixed in 1.35.5, 1.36.3, 1.37.1
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.35.5, 1.36.3, 1.37.1. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/q/I58d37fb59f998f5bec4a018bf9da96a777f8ff78
- https://phabricator.wikimedia.org/T293556
- https://gerrit.wikimedia.org/r/q/I58d37fb59f998f5bec4a018bf9da96a777f8ff78
- https://phabricator.wikimedia.org/T293556
Get alerted when CVE-2021-46146 or the next vulnerability affects your stack