What’s Vulnerable › Vulnerabilities
CVE-2021-46147
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-10 · updated 2026-06-17
- Weakness: CWE-352
Description
An issue was discovered in MediaWiki before 1.35.5, 1.36.x before 1.36.3, and 1.37.x before 1.37.1. MassEditRegex allows CSRF.
Affected products
- Wikimedia Foundation MediaWiki: before 1.35.5; from 1.36.0 before 1.36.3; from 1.37.0 before 1.37.1 — fixed in 1.35.5, 1.36.3, 1.37.1
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.35.5, 1.36.3, 1.37.1. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/q/I5980de35b0a01b5242b68b7b0bdc08adf5d968d8
- https://phabricator.wikimedia.org/T293341
- https://gerrit.wikimedia.org/r/q/I5980de35b0a01b5242b68b7b0bdc08adf5d968d8
- https://phabricator.wikimedia.org/T293341
Get alerted when CVE-2021-46147 or the next vulnerability affects your stack