What’s Vulnerable › Vulnerabilities
CVE-2021-46150
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-10 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in MediaWiki before 1.35.5, 1.36.x before 1.36.3, and 1.37.x before 1.37.1. Special:CheckUserLog allows CheckUser XSS because of date mishandling, as demonstrated by an XSS payload in MediaWiki:October.
Affected products
- Wikimedia Foundation MediaWiki: before 1.35.5; from 1.36.0 before 1.36.3; from 1.37.0 before 1.37.1 — fixed in 1.35.5, 1.36.3, 1.37.1
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.35.5, 1.36.3, 1.37.1. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/plugins/gitiles/mediawiki/extensions/CheckUser/+/79c2c49a18f96b159258958feca90fce964c350a
- https://phabricator.wikimedia.org/T292795
- https://gerrit.wikimedia.org/r/plugins/gitiles/mediawiki/extensions/CheckUser/+/79c2c49a18f96b159258958feca90fce964c350a
- https://phabricator.wikimedia.org/T292795
Get alerted when CVE-2021-46150 or the next vulnerability affects your stack