What’s Vulnerable › Vulnerabilities
CVE-2021-46174
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-22 · updated 2026-06-17
- Weakness: CWE-787
Description
Heap-based Buffer Overflow in function bfd_getl32 in Binutils objdump 3.37.
Affected products
- GNU Binutils: before 2.38 — fixed in 2.38
How to fix
Upgrade to a fixed version: GNU Binutils 2.38. Check the vendor advisory for mitigations.
References
- https://sourceware.org/bugzilla/show_bug.cgi?id=28753
- https://sourceware.org/bugzilla/show_bug.cgi?id=28753
Get alerted when CVE-2021-46174 or the next vulnerability affects your stack