What’s Vulnerable › Vulnerabilities
CVE-2021-46179
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-22 · updated 2026-06-17
- Weakness: CWE-617
Description
Reachable Assertion vulnerability in upx before 4.0.0 allows attackers to cause a denial of service via crafted file passed to the the readx function.
Affected products
- upx: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: upx 4.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-46179 or the next vulnerability affects your stack