What’s Vulnerable › Vulnerabilities
CVE-2021-46643
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-18 · updated 2026-06-17
- Weakness: CWE-121
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of Bentley View 10.15.0.75. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of DGN files. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-15515.
Affected products
- Bentley MicroStation: before 10.16.02 — fixed in 10.16.02
- Bentley View: before 10.16.02 — fixed in 10.16.02
How to fix
Upgrade to a fixed version: Bentley MicroStation 10.16.02; Bentley View 10.16.02. Check the vendor advisory for mitigations.
References
- https://www.bentley.com/en/common-vulnerability-exposure/BE-2021-0009
- https://www.zerodayinitiative.com/advisories/ZDI-22-230/
- https://www.bentley.com/en/common-vulnerability-exposure/BE-2021-0009
- https://www.zerodayinitiative.com/advisories/ZDI-22-230/
Get alerted when CVE-2021-46643 or the next vulnerability affects your stack