What’s Vulnerable › Vulnerabilities

CVE-2021-46659

Description

MariaDB before 10.7.2 allows an application crash because it does not recognize that SELECT_LEX::nest_level is local to each VIEW.

Affected products

How to fix

Upgrade to a fixed version: MariaDB 10.2.42, 10.3.33, 10.4.23, 10.5.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-46659 or the next vulnerability affects your stack