What’s Vulnerable › Vulnerabilities
CVE-2021-46704
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 21.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-06 · updated 2026-06-17
- Weakness: CWE-78
Description
In GenieACS 1.2.x before 1.2.8, the UI interface API is vulnerable to unauthenticated OS command injection via the ping host argument (lib/ui/api.ts and lib/ping.ts). The vulnerability arises from insufficient input validation combined with a missing authorization check.
Affected products
- Genieacs: from 1.2.0 before 1.2.8 — fixed in 1.2.8
How to fix
Upgrade to a fixed version: Genieacs 1.2.8. Check the vendor advisory for mitigations.
References
- https://github.com/genieacs/genieacs/commit/7f295beeecc1c1f14308a93c82413bb334045af6
- https://github.com/genieacs/genieacs/releases/tag/v1.2.8
- https://github.com/genieacs/genieacs/commit/7f295beeecc1c1f14308a93c82413bb334045af6
- https://github.com/genieacs/genieacs/releases/tag/v1.2.8
Get alerted when CVE-2021-46704 or the next vulnerability affects your stack