What’s Vulnerable › Vulnerabilities
CVE-2021-46708
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-11 · updated 2026-06-17
- Weakness: CWE-1021
Description
The swagger-ui-dist package before 4.1.3 for Node.js could allow a remote attacker to hijack the clicking action of the victim. By persuading a victim to visit a malicious Web site, a remote attacker could exploit this vulnerability to hijack the victim's click actions and possibly launch further attacks against the victim.
Affected products
- SMARTBEAR Swagger-Ui-Dist: before 4.1.3 — fixed in 4.1.3
How to fix
Upgrade to a fixed version: SMARTBEAR Swagger-Ui-Dist 4.1.3. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20220407-0004/
- https://security.snyk.io/vuln/SNYK-JS-SWAGGERUIDIST-2314884
- https://www.npmjs.com/package/swagger-ui-dist/v/4.1.3
- https://security.netapp.com/advisory/ntap-20220407-0004/
- https://security.snyk.io/vuln/SNYK-JS-SWAGGERUIDIST-2314884
- https://www.npmjs.com/package/swagger-ui-dist/v/4.1.3
Get alerted when CVE-2021-46708 or the next vulnerability affects your stack