What’s Vulnerable › Vulnerabilities
CVE-2021-46784
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-17 · updated 2026-06-17
- Weakness: CWE-617
Description
In Squid 3.x through 3.5.28, 4.x through 4.17, and 5.x before 5.6, due to improper buffer management, a Denial of Service can occur when processing long Gopher server responses.
Affected products
- Debian Linux: 10.0, 11.0, 12.0
- Squid: from 3.0 through 3.5.28; from 4.0 through 4.17; from 5.0 before 5.6 — fixed in 5.6
How to fix
Upgrade to a fixed version: Squid 5.6. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/10/13/1
- http://www.openwall.com/lists/oss-security/2023/10/13/10
- http://www.openwall.com/lists/oss-security/2023/10/21/1
- http://www.squid-cache.org/Versions/v4/changesets/SQUID-2021_7.patch
- http://www.squid-cache.org/Versions/v5/changesets/SQUID-2021_7.patch
- https://github.com/squid-cache/squid/commit/5e2ea2b13bd98f53e29964ca26bb0d602a8a12b9
- https://github.com/squid-cache/squid/security/advisories/GHSA-f5cp-6rh3-284w
- https://security-tracker.debian.org/tracker/CVE-2021-46784
- https://security.netapp.com/advisory/ntap-20221223-0007/
- http://www.openwall.com/lists/oss-security/2023/10/13/1
- http://www.openwall.com/lists/oss-security/2023/10/13/10
- http://www.openwall.com/lists/oss-security/2023/10/21/1
Get alerted when CVE-2021-46784 or the next vulnerability affects your stack