What’s Vulnerable › Vulnerabilities
CVE-2021-46880
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-15 · updated 2026-06-17
- Weakness: CWE-295
Description
x509/x509_verify.c in LibreSSL before 3.4.2, and OpenBSD before 7.0 errata 006, allows authentication bypass because an error for an unverified certificate chain is sometimes discarded.
Affected products
- OpenBSD Libressl: before 3.4.2 — fixed in 3.4.2
- OpenBSD: before 7.0 — fixed in 7.0
How to fix
Upgrade to a fixed version: OpenBSD Libressl 3.4.2; OpenBSD 7.0. Check the vendor advisory for mitigations.
References
- https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-3.4.2-relnotes.txt
- https://ftp.openbsd.org/pub/OpenBSD/patches/7.0/common/006_x509.patch.sig
- https://github.com/openbsd/src/commit/3f851282810fa0ab4b90b3b1ecec2e8717ef16f8
- https://security.netapp.com/advisory/ntap-20230517-0006/
- https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-3.4.2-relnotes.txt
- https://ftp.openbsd.org/pub/OpenBSD/patches/7.0/common/006_x509.patch.sig
- https://github.com/openbsd/src/commit/3f851282810fa0ab4b90b3b1ecec2e8717ef16f8
- https://security.netapp.com/advisory/ntap-20230517-0006/
Get alerted when CVE-2021-46880 or the next vulnerability affects your stack