What’s Vulnerable › Vulnerabilities
CVE-2021-46888
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-21 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in hledger before 1.23. A Stored Cross-Site Scripting (XSS) vulnerability exists in toBloodhoundJson that allows an attacker to execute JavaScript by encoding user-controlled values in a payload with base64 and parsing them with the atob function.
Affected products
- Hledger: before 1.23 — fixed in 1.23
How to fix
Upgrade to a fixed version: Hledger 1.23. Check the vendor advisory for mitigations.
References
- https://github.com/simonmichael/hledger/issues/1525
- https://github.com/simonmichael/hledger/pull/1663
- https://github.com/simonmichael/hledger/releases/tag/1.23
- https://www.youtube.com/watch?v=QnRO-VkfIic
- https://github.com/simonmichael/hledger/issues/1525
- https://github.com/simonmichael/hledger/pull/1663
- https://github.com/simonmichael/hledger/releases/tag/1.23
- https://www.youtube.com/watch?v=QnRO-VkfIic
Get alerted when CVE-2021-46888 or the next vulnerability affects your stack