What’s Vulnerable › Vulnerabilities
CVE-2021-46909: ARM: footbridge: fix PCI interrupt mapping
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-27 · updated 2026-06-17
- Weakness: CWE-754
Description
In the Linux kernel, the following vulnerability has been resolved: ARM: footbridge: fix PCI interrupt mapping Since commit 30fdfb929e82 ("PCI: Add a call to pci_assign_irq() in pci_device_probe()"), the PCI code will call the IRQ mapping function whenever a PCI driver is probed. If these are marked as __init, this causes an oops if a PCI driver is loaded or bound after the kernel has initialised.
Affected products
- Linux kernel: from 4.13.0 before 4.14.232; from 4.15.0 before 4.19.189; from 4.20.0 before 5.4.114; from 5.5.0 before 5.10.32; from 5.11.0 before 5.11.16 — fixed in 4.14.232, 4.19.189, 5.10.32, 5.11.16, 5.4.114
How to fix
Upgrade to a fixed version: Linux kernel 4.14.232, 4.19.189, 5.10.32, 5.11.16. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1fc087fdb98d556b416c82ed6e3964a30885f47a
- https://git.kernel.org/stable/c/2643da6aa57920d9159a1a579fb04f89a2b0d29a
- https://git.kernel.org/stable/c/30e3b4f256b4e366a61658c294f6a21b8626dda7
- https://git.kernel.org/stable/c/532747fd5c7aaa17ee5cf79f3e947c31eb0e35cf
- https://git.kernel.org/stable/c/871b569a3e67f570df9f5ba195444dc7c621293b
- https://git.kernel.org/stable/c/c3efce8cc9807339633ee30e39882f4c8626ee1d
- https://git.kernel.org/stable/c/1fc087fdb98d556b416c82ed6e3964a30885f47a
- https://git.kernel.org/stable/c/2643da6aa57920d9159a1a579fb04f89a2b0d29a
- https://git.kernel.org/stable/c/30e3b4f256b4e366a61658c294f6a21b8626dda7
- https://git.kernel.org/stable/c/532747fd5c7aaa17ee5cf79f3e947c31eb0e35cf
- https://git.kernel.org/stable/c/871b569a3e67f570df9f5ba195444dc7c621293b
- https://git.kernel.org/stable/c/c3efce8cc9807339633ee30e39882f4c8626ee1d
Get alerted when CVE-2021-46909 or the next vulnerability affects your stack