What’s Vulnerable › Vulnerabilities
CVE-2021-46920: dmaengine: idxd: Fix clobbering of SWERR overflow bit on writeback
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-27 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: dmaengine: idxd: Fix clobbering of SWERR overflow bit on writeback Current code blindly writes over the SWERR and the OVERFLOW bits. Write back the bits actually read instead so the driver avoids clobbering the OVERFLOW bit that comes after the register is read.
Affected products
- Linux kernel: from 5.6.0 before 5.10.32; from 5.11.0 before 5.11.16 — fixed in 5.10.32, 5.11.16
How to fix
Upgrade to a fixed version: Linux kernel 5.10.32, 5.11.16. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/02981a44a0e402089775416371bd2e0c935685f8
- https://git.kernel.org/stable/c/a5ad12d5d69c63af289a37f05187a0c6fe93553d
- https://git.kernel.org/stable/c/ea941ac294d75d0ace50797aebf0056f6f8f7a7f
- https://git.kernel.org/stable/c/02981a44a0e402089775416371bd2e0c935685f8
- https://git.kernel.org/stable/c/a5ad12d5d69c63af289a37f05187a0c6fe93553d
- https://git.kernel.org/stable/c/ea941ac294d75d0ace50797aebf0056f6f8f7a7f
Get alerted when CVE-2021-46920 or the next vulnerability affects your stack