What’s Vulnerable › Vulnerabilities
CVE-2021-46934: i2c: validate user data in compat ioctl
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-27 · updated 2026-06-17
- Weakness: CWE-754
Description
In the Linux kernel, the following vulnerability has been resolved: i2c: validate user data in compat ioctl Wrong user data may cause warning in i2c_transfer(), ex: zero msgs. Userspace should not be able to trigger warnings, so this patch adds validation checks for user data in compact ioctl to prevent reported warnings
Affected products
- Linux kernel: from 4.15.0 before 4.19.224; from 4.20.0 before 5.4.170; from 5.5.0 before 5.10.90; from 5.11.0 before 5.15.13 — fixed in 4.19.224, 5.10.90, 5.15.13, 5.4.170
How to fix
Upgrade to a fixed version: Linux kernel 4.19.224, 5.10.90, 5.15.13, 5.4.170. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/407c8708fb1bf2d4afc5337ef50635cf540c364b
- https://git.kernel.org/stable/c/8d31cbab4c295d7010ebb729e9d02d0e9cece18f
- https://git.kernel.org/stable/c/9e4a3f47eff476097e0c7faac04d1831fc70237d
- https://git.kernel.org/stable/c/bb436283e25aaf1533ce061605d23a9564447bdf
- https://git.kernel.org/stable/c/f68599581067e8a5a8901ba9eb270b4519690e26
- https://git.kernel.org/stable/c/407c8708fb1bf2d4afc5337ef50635cf540c364b
- https://git.kernel.org/stable/c/8d31cbab4c295d7010ebb729e9d02d0e9cece18f
- https://git.kernel.org/stable/c/9e4a3f47eff476097e0c7faac04d1831fc70237d
- https://git.kernel.org/stable/c/bb436283e25aaf1533ce061605d23a9564447bdf
- https://git.kernel.org/stable/c/f68599581067e8a5a8901ba9eb270b4519690e26
Get alerted when CVE-2021-46934 or the next vulnerability affects your stack