What’s Vulnerable › Vulnerabilities
CVE-2021-46999: sctp: do asoc update earlier in sctp_sf_do_dupcook_a
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-28 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: sctp: do asoc update earlier in sctp_sf_do_dupcook_a There's a panic that occurs in a few of envs, the call trace is as below: [] general protection fault, ... 0x29acd70f1000a: 0000 [#1] SMP PTI [] RIP: 0010:sctp_ulpevent_notify_peer_addr_change+0x4b/0x1fa [sctp] [] sctp_assoc_control_transport+0x1b9/0x210 [sctp] [] sctp_do_8_2_transport_strike.isra.16+0x15c/0x220 [sctp] [] sctp_cmd_interpreter.isra.21+0x1231/0x1a10 [sctp] [] sctp_do_sm+0xc3/0x2a0 [sctp] [] sctp_generate_timeout_event+0x81/0xf0 [sctp] This is caused by a transport use-after-free issue. When processing a duplicate COOKIE-ECHO chunk in sctp_sf_do_dupcook_a(), both COOKIE-ACK and SHUTDOWN chunks are allocated with the transort from the new asoc. However, later in the sideeffect machine, the old asoc is used to send them out and old asoc's shutdown_last_sent_to is set to the transport that SHUTDOWN chunk attached to in sctp_cmd_setup_t2(), which actually belongs to the new asoc. After the new_asoc is freed and the old asoc T2 timeout, the old asoc's shutdown_last_sent_to that is already freed would be accessed in sctp_sf_t2_timer_expire(). Thanks Alexander and Jere for helping dig into this issue. To fix it, this patch is to do the asoc update first, then allocate the COOKIE-ACK and SHUTDOWN chunks with the 'updated' old asoc. This would make more sense, as a chunk from an asoc shouldn't be sent out with another asoc. We had fixed quite a few issues caused by this.
Affected products
- Linux kernel: from 4.19.123 before 4.19.191; from 5.4.41 before 5.4.120; from 5.7 before 5.10.38; from 5.11 before 5.11.22; from 5.12 before 5.12.5 — fixed in 4.19.191, 5.10.38, 5.11.22, 5.12.5, 5.4.120
How to fix
Upgrade to a fixed version: Linux kernel 4.19.191, 5.10.38, 5.11.22, 5.12.5. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0bfd913c2121b3d553bfd52810fe6061d542d625
- https://git.kernel.org/stable/c/35b4f24415c854cd718ccdf38dbea6297f010aae
- https://git.kernel.org/stable/c/61b877bad9bb0d82b7d8841be50872557090a704
- https://git.kernel.org/stable/c/b1b31948c0af44628e43353828453461bb74098f
- https://git.kernel.org/stable/c/d624f2991b977821375fbd56c91b0c91d456a697
- https://git.kernel.org/stable/c/f01988ecf3654f805282dce2d3bb9afe68d2691e
- https://git.kernel.org/stable/c/0bfd913c2121b3d553bfd52810fe6061d542d625
- https://git.kernel.org/stable/c/35b4f24415c854cd718ccdf38dbea6297f010aae
- https://git.kernel.org/stable/c/61b877bad9bb0d82b7d8841be50872557090a704
- https://git.kernel.org/stable/c/b1b31948c0af44628e43353828453461bb74098f
- https://git.kernel.org/stable/c/d624f2991b977821375fbd56c91b0c91d456a697
- https://git.kernel.org/stable/c/f01988ecf3654f805282dce2d3bb9afe68d2691e
Get alerted when CVE-2021-46999 or the next vulnerability affects your stack