What’s Vulnerable › Vulnerabilities
CVE-2021-47055: mtd: require write permissions for locking and badblock ioctls
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-29 · updated 2026-08-04
- Weakness: CWE-667
Description
In the Linux kernel, the following vulnerability has been resolved: mtd: require write permissions for locking and badblock ioctls MEMLOCK, MEMUNLOCK and OTPLOCK modify protection bits. Thus require write permission. Depending on the hardware MEMLOCK might even be write-once, e.g. for SPI-NOR flashes with their WP# tied to GND. OTPLOCK is always write-once. MEMSETBADBLOCK modifies the bad block table.
Affected products
- Linux kernel: from 4.4.233 before 4.4.269; from 4.9.233 before 4.9.269; from 4.14.194 before 4.14.233; from 4.19.139 before 4.19.191; from 5.4.58 before 5.4.119; from 5.9 before 5.10.37 — fixed in 4.14.233, 4.19.191, 4.4.269, 4.9.269, 5.10.37, 5.11.21
How to fix
Upgrade to a fixed version: Linux kernel 4.14.233, 4.19.191, 4.4.269, 4.9.269. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/077259f5e777c3c8821f6b41dee709fcda27306b
- https://git.kernel.org/stable/c/1e97743fd180981bef5f01402342bb54bf1c6366
- https://git.kernel.org/stable/c/5880afefe0cb9b2d5e801816acd58bfe91a96981
- https://git.kernel.org/stable/c/75ed985bd6c8ac1d4e673e93ea9d96c9908c1d37
- https://git.kernel.org/stable/c/7b6552719c0ccbbea29dde4be141da54fdb5877e
- https://git.kernel.org/stable/c/9625b00cac6630479c0ff4b9fafa88bee636e1f0
- https://git.kernel.org/stable/c/a08799d3e8c8088640956237c183f83463c39668
- https://git.kernel.org/stable/c/f4d28d8b9b0e7c4ae04214b8d7e0b0466ec6bcaf
- https://git.kernel.org/stable/c/f73b29819c6314c0ba8b7d5892dfb03487424bee
- https://git.kernel.org/stable/c/077259f5e777c3c8821f6b41dee709fcda27306b
- https://git.kernel.org/stable/c/1e97743fd180981bef5f01402342bb54bf1c6366
- https://git.kernel.org/stable/c/5880afefe0cb9b2d5e801816acd58bfe91a96981
Get alerted when CVE-2021-47055 or the next vulnerability affects your stack