What’s Vulnerable › Vulnerabilities
CVE-2021-47157
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-18 · updated 2026-06-17
- Weakness: CWE-346
Description
The Kossy module before 0.60 for Perl allows JSON hijacking because of X-Requested-With mishandling.
Affected products
- Kossy: before 0.60 — fixed in 0.60
How to fix
Upgrade to a fixed version: Kossy 0.60. Check the vendor advisory for mitigations.
References
- https://github.com/kazeburo/Kossy/pull/16
- https://metacpan.org/dist/Kossy/changes
- https://github.com/kazeburo/Kossy/pull/16
- https://metacpan.org/dist/Kossy/changes
Get alerted when CVE-2021-47157 or the next vulnerability affects your stack