What’s Vulnerable › Vulnerabilities
CVE-2021-47168: NFS: fix an incorrect limit in filelayout_decode_layout()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-25 · updated 2026-08-04
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: NFS: fix an incorrect limit in filelayout_decode_layout() The "sizeof(struct nfs_fh)" is two bytes too large and could lead to memory corruption. It should be NFS_MAXFHSIZE because that's the size of the ->data[] buffer. I reversed the size of the arguments to put the variable on the left.
Affected products
- Linux kernel: from 2.6.37 before 4.4.271; from 4.5 before 4.9.271; from 4.10 before 4.14.235; from 4.15 before 4.19.193; from 4.20 before 5.4.124; from 5.5 before 5.10.42 — fixed in 4.14.235, 4.19.193, 4.4.271, 4.9.271, 5.10.42, 5.12.9
How to fix
Upgrade to a fixed version: Linux kernel 4.14.235, 4.19.193, 4.4.271, 4.9.271. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/769b01ea68b6c49dc3cde6adf7e53927dacbd3a8
- https://git.kernel.org/stable/c/945ebef997227ca8c20bad7f8a8358c8ee57a84a
- https://git.kernel.org/stable/c/9b367fe770b1b80d7bf64ed0d177544a44405f6e
- https://git.kernel.org/stable/c/9d280ab53df1d4a1043bd7a9e7c6a2f9cfbfe040
- https://git.kernel.org/stable/c/b287521e9e94bb342ebe5fd8c3fd7db9aef4e6f1
- https://git.kernel.org/stable/c/d34fb628f6ef522f996205a9e578216bbee09e84
- https://git.kernel.org/stable/c/e411df81cd862ef3d5b878120b2a2fef0ca9cdb1
- https://git.kernel.org/stable/c/f299522eda1566cbfbae4b15c82970fc41b03714
- https://git.kernel.org/stable/c/769b01ea68b6c49dc3cde6adf7e53927dacbd3a8
- https://git.kernel.org/stable/c/945ebef997227ca8c20bad7f8a8358c8ee57a84a
- https://git.kernel.org/stable/c/9b367fe770b1b80d7bf64ed0d177544a44405f6e
- https://git.kernel.org/stable/c/9d280ab53df1d4a1043bd7a9e7c6a2f9cfbfe040
Get alerted when CVE-2021-47168 or the next vulnerability affects your stack