What’s Vulnerable › Vulnerabilities
CVE-2021-47208
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-08 · updated 2026-06-17
- Weakness: CWE-400
Description
The Mojolicious module before 9.11 for Perl has a bug in format detection that can potentially be exploited for denial of service.
Affected products
- SRI Mojolicious: before 9.11 — fixed in 9.11
How to fix
Upgrade to a fixed version: SRI Mojolicious 9.11. Check the vendor advisory for mitigations.
References
- https://github.com/mojolicious/mojo/commit/a0c4576ffb11c235088550de9ba7ac4196e1953c
- https://github.com/mojolicious/mojo/issues/1736
- https://github.com/mojolicious/mojo/commit/a0c4576ffb11c235088550de9ba7ac4196e1953c
- https://github.com/mojolicious/mojo/issues/1736
Get alerted when CVE-2021-47208 or the next vulnerability affects your stack