What’s Vulnerable › Vulnerabilities
CVE-2021-47240: net: qrtr: fix OOB Read in qrtr_endpoint_post
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-08-04
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: net: qrtr: fix OOB Read in qrtr_endpoint_post Syzbot reported slab-out-of-bounds Read in qrtr_endpoint_post. The problem was in wrong _size_ type: if (len != ALIGN(size, 4) + hdrlen) goto err; If size from qrtr_hdr is 4294967293 (0xfffffffd), the result of ALIGN(size, 4) will be 0. In case of len == hdrlen and size == 4294967293 in header this check won't fail and skb_put_data(skb, data + hdrlen, size); will read out of bound from data, which is hdrlen allocated block.
Affected products
- Linux kernel: from 4.15 before 4.19.196; from 4.20 before 5.4.128; from 5.5 before 5.10.46; from 5.11 before 5.12.13; 5.13-rc1, 5.13-rc2, 5.13-rc3, 5.13-rc4, 5.13-rc5, 5.13-rc6 — fixed in 4.19.196, 5.10.46, 5.12.13, 5.4.128
How to fix
Upgrade to a fixed version: Linux kernel 4.19.196, 5.10.46, 5.12.13, 5.4.128. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/19892ab9c9d838e2e5a7744d36e4bb8b7c3292fe
- https://git.kernel.org/stable/c/26b8d10703a9be45d6097946b2b4011f7dd2c56f
- https://git.kernel.org/stable/c/960b08dd36de1e341e3eb43d1c547513e338f4f8
- https://git.kernel.org/stable/c/ad9d24c9429e2159d1e279dc3a83191ccb4daf1d
- https://git.kernel.org/stable/c/f8111c0d7ed42ede41a3d0d393b104de0730a8a6
- https://git.kernel.org/stable/c/19892ab9c9d838e2e5a7744d36e4bb8b7c3292fe
- https://git.kernel.org/stable/c/26b8d10703a9be45d6097946b2b4011f7dd2c56f
- https://git.kernel.org/stable/c/960b08dd36de1e341e3eb43d1c547513e338f4f8
- https://git.kernel.org/stable/c/ad9d24c9429e2159d1e279dc3a83191ccb4daf1d
- https://git.kernel.org/stable/c/f8111c0d7ed42ede41a3d0d393b104de0730a8a6
Get alerted when CVE-2021-47240 or the next vulnerability affects your stack