What’s Vulnerable › Vulnerabilities
CVE-2021-47278: bus: mhi: pci_generic: Fix possible use-after-free in mhi_pci_remove()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: bus: mhi: pci_generic: Fix possible use-after-free in mhi_pci_remove() This driver's remove path calls del_timer(). However, that function does not wait until the timer handler finishes. This means that the timer handler may still be running after the driver's remove function has finished, which would result in a use-after-free. Fix by calling del_timer_sync(), which makes sure the timer handler has finished, and unable to re-schedule itself.
Affected products
- Linux kernel: from 5.12 before 5.12.11; 5.13-rc1, 5.13-rc2, 5.13-rc3, 5.13-rc4, 5.13-rc5 — fixed in 5.12.11
How to fix
Upgrade to a fixed version: Linux kernel 5.12.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0b67808ade8893a1b3608ddd74fac7854786c919
- https://git.kernel.org/stable/c/c597d5c59c7a6417dba06590f59b922e01188e8d
- https://git.kernel.org/stable/c/0b67808ade8893a1b3608ddd74fac7854786c919
- https://git.kernel.org/stable/c/c597d5c59c7a6417dba06590f59b922e01188e8d
Get alerted when CVE-2021-47278 or the next vulnerability affects your stack