What’s Vulnerable › Vulnerabilities
CVE-2021-47308: scsi: libfc: Fix array index out of bound exception
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-08-04
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: libfc: Fix array index out of bound exception Fix array index out of bound exception in fc_rport_prli_resp().
Affected products
- Linux kernel: before 4.14.241; from 4.15 before 4.19.199; from 4.20 before 5.4.135; from 5.5 before 5.10.53; from 5.11 before 5.13.5 — fixed in 4.14.241, 4.19.199, 5.10.53, 5.13.5, 5.4.135
How to fix
Upgrade to a fixed version: Linux kernel 4.14.241, 4.19.199, 5.10.53, 5.13.5. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0fe70c15f9435bb3c50954778245d62ee38b0e03
- https://git.kernel.org/stable/c/44651522941c623e20882b3b443f23f77de1ea8b
- https://git.kernel.org/stable/c/4921b1618045ffab71b1050bf0014df3313a2289
- https://git.kernel.org/stable/c/8511293e643a18b248510ae5734e4f360754348c
- https://git.kernel.org/stable/c/a4a54c54af2516caa9c145015844543cfc84316a
- https://git.kernel.org/stable/c/b27c4577557045f1ab3cdfeabfc7f3cd24aca1fe
- https://git.kernel.org/stable/c/0fe70c15f9435bb3c50954778245d62ee38b0e03
- https://git.kernel.org/stable/c/44651522941c623e20882b3b443f23f77de1ea8b
- https://git.kernel.org/stable/c/4921b1618045ffab71b1050bf0014df3313a2289
- https://git.kernel.org/stable/c/8511293e643a18b248510ae5734e4f360754348c
- https://git.kernel.org/stable/c/a4a54c54af2516caa9c145015844543cfc84316a
- https://git.kernel.org/stable/c/b27c4577557045f1ab3cdfeabfc7f3cd24aca1fe
Get alerted when CVE-2021-47308 or the next vulnerability affects your stack