What’s Vulnerable › Vulnerabilities
CVE-2021-47347: wl1251: Fix possible buffer overflow in wl1251_cmd_scan
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-08-04
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: wl1251: Fix possible buffer overflow in wl1251_cmd_scan Function wl1251_cmd_scan calls memcpy without checking the length. Harden by checking the length is within the maximum allowed size.
Affected products
- Linux kernel: before 4.4.276; from 4.5 before 4.9.276; from 4.10 before 4.14.240; from 4.15 before 4.19.198; from 4.20 before 5.4.133; from 5.5 before 5.10.51 — fixed in 4.14.240, 4.19.198, 4.4.276, 4.9.276, 5.10.51, 5.12.18
How to fix
Upgrade to a fixed version: Linux kernel 4.14.240, 4.19.198, 4.4.276, 4.9.276. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0f6c0488368c9ac1aa685821916fadba32f5d1ef
- https://git.kernel.org/stable/c/115103f6e3f1c26c473766c16439c7c8b235529a
- https://git.kernel.org/stable/c/302e2ee34c5f7c5d805b7f835d9a6f2b43474e2a
- https://git.kernel.org/stable/c/40af3960a15339e8bbd3be50c3bc7b35e1a0b6ea
- https://git.kernel.org/stable/c/57ad99ae3c6738ba87bad259bb57c641ca68ebf6
- https://git.kernel.org/stable/c/c5e4a10d7bd5d4f419d8b9705dff60cf69b302a1
- https://git.kernel.org/stable/c/d10a87a3535cce2b890897914f5d0d83df669c63
- https://git.kernel.org/stable/c/d3d8b9c9c7843dce31e284927d4c9904fd5a510a
- https://git.kernel.org/stable/c/d71dddeb5380613f9ef199f3e7368fd78fb1a46e
- https://git.kernel.org/stable/c/0f6c0488368c9ac1aa685821916fadba32f5d1ef
- https://git.kernel.org/stable/c/115103f6e3f1c26c473766c16439c7c8b235529a
- https://git.kernel.org/stable/c/302e2ee34c5f7c5d805b7f835d9a6f2b43474e2a
Get alerted when CVE-2021-47347 or the next vulnerability affects your stack