What’s Vulnerable › Vulnerabilities
CVE-2021-47373: irqchip/gic-v3-its: Fix potential VPE leak on error
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-193
Description
In the Linux kernel, the following vulnerability has been resolved: irqchip/gic-v3-its: Fix potential VPE leak on error In its_vpe_irq_domain_alloc, when its_vpe_init() returns an error, there is an off-by-one in the number of VPEs to be freed. Fix it by simply passing the number of VPEs allocated, which is the index of the loop iterating over the VPEs. [maz: fixed commit message]
Affected products
- Linux kernel: from 4.14 before 4.14.249; from 4.15 before 4.19.209; from 4.20 before 5.4.150; from 5.5 before 5.10.70; from 5.11 before 5.14.9; 5.15-rc1, 5.15-rc2 — fixed in 4.14.249, 4.19.209, 5.10.70, 5.14.9, 5.4.150
How to fix
Upgrade to a fixed version: Linux kernel 4.14.249, 4.19.209, 5.10.70, 5.14.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/280bef512933b2dda01d681d8cbe499b98fc5bdd
- https://git.kernel.org/stable/c/42d3711c23781045e7a5cd28536c774b9a66d20b
- https://git.kernel.org/stable/c/568662e37f927e3dc3e475f3ff7cf4ab7719c5e7
- https://git.kernel.org/stable/c/5701e8bff314c155e7afdc467b1e0389d86853d0
- https://git.kernel.org/stable/c/7d39992d45acd6f2d6b2f62389c55b61fb3d486b
- https://git.kernel.org/stable/c/e0c1c2e5da19685a20557a50f10c6aa4fa26aa84
- https://git.kernel.org/stable/c/280bef512933b2dda01d681d8cbe499b98fc5bdd
- https://git.kernel.org/stable/c/42d3711c23781045e7a5cd28536c774b9a66d20b
- https://git.kernel.org/stable/c/568662e37f927e3dc3e475f3ff7cf4ab7719c5e7
- https://git.kernel.org/stable/c/5701e8bff314c155e7afdc467b1e0389d86853d0
- https://git.kernel.org/stable/c/7d39992d45acd6f2d6b2f62389c55b61fb3d486b
- https://git.kernel.org/stable/c/e0c1c2e5da19685a20557a50f10c6aa4fa26aa84
Get alerted when CVE-2021-47373 or the next vulnerability affects your stack