What’s Vulnerable › Vulnerabilities
CVE-2021-47403: ipack: ipoctal: fix module reference leak
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-200
Description
In the Linux kernel, the following vulnerability has been resolved: ipack: ipoctal: fix module reference leak A reference to the carrier module was taken on every open but was only released once when the final reference to the tty struct was dropped. Fix this by taking the module reference and initialising the tty driver data when installing the tty.
Affected products
- Linux kernel: from 3.18 before 4.4.286; from 4.5 before 4.9.285; from 4.10 before 4.14.249; from 4.15 before 4.19.209; from 4.20 before 5.4.151; from 5.5 before 5.10.71 — fixed in 4.14.249, 4.19.209, 4.4.286, 4.9.285, 5.10.71, 5.14.10
How to fix
Upgrade to a fixed version: Linux kernel 4.14.249, 4.19.209, 4.4.286, 4.9.285. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/31398849b84ebae0d43a1cf379cb9895597f221a
- https://git.kernel.org/stable/c/3253c87e1e5bc0107aab773af2f135ebccf38666
- https://git.kernel.org/stable/c/7cea848678470daadbfdaa6a112b823c290f900c
- https://git.kernel.org/stable/c/811178f296b16af30264def74c8d2179a72d5562
- https://git.kernel.org/stable/c/9c5b77a7ffc983b2429ce158b50497c5d3c86a69
- https://git.kernel.org/stable/c/bb8a4fcb2136508224c596a7e665bdba1d7c3c27
- https://git.kernel.org/stable/c/c0adb5a947dec6cff7050ec56d78ecd3916f9ce6
- https://git.kernel.org/stable/c/dde4c1429b97383689f755ce92b4ed1e84a9c92b
- https://git.kernel.org/stable/c/31398849b84ebae0d43a1cf379cb9895597f221a
- https://git.kernel.org/stable/c/3253c87e1e5bc0107aab773af2f135ebccf38666
- https://git.kernel.org/stable/c/7cea848678470daadbfdaa6a112b823c290f900c
- https://git.kernel.org/stable/c/811178f296b16af30264def74c8d2179a72d5562
Get alerted when CVE-2021-47403 or the next vulnerability affects your stack