What’s Vulnerable › Vulnerabilities
CVE-2021-47442: NFC: digital: fix possible memory leak in digital_in_send_sdd_req()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-22 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: NFC: digital: fix possible memory leak in digital_in_send_sdd_req() 'skb' is allocated in digital_in_send_sdd_req(), but not free when digital_in_send_cmd() failed, which will cause memory leak. Fix it by freeing 'skb' if digital_in_send_cmd() return failed.
Affected products
- Linux kernel: from 3.13 before 4.4.290; from 4.5 before 4.9.288; from 4.10 before 4.14.252; from 4.15 before 4.19.213; from 4.20 before 5.4.155; from 5.5 before 5.10.75 — fixed in 4.14.252, 4.19.213, 4.4.290, 4.9.288, 5.10.75, 5.14.14
How to fix
Upgrade to a fixed version: Linux kernel 4.14.252, 4.19.213, 4.4.290, 4.9.288. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/071bdef36391958c89af5fa2172f691b31baa212
- https://git.kernel.org/stable/c/291c932fc3692e4d211a445ba8aa35663831bac7
- https://git.kernel.org/stable/c/2bde4aca56db9fe25405d39ddb062531493a65db
- https://git.kernel.org/stable/c/50cb95487c265187289810addec5093d4fed8329
- https://git.kernel.org/stable/c/6432d7f1d1c3aa74cfe8f5e3afdf81b786c32e86
- https://git.kernel.org/stable/c/74569c78aa84f8c958f1334b465bc530906ec99a
- https://git.kernel.org/stable/c/88c890b0b9a1fb9fcd01c61ada515e8b636c34f9
- https://git.kernel.org/stable/c/fcce6e5255474ca33c27dda0cdf9bf5087278873
- https://git.kernel.org/stable/c/071bdef36391958c89af5fa2172f691b31baa212
- https://git.kernel.org/stable/c/291c932fc3692e4d211a445ba8aa35663831bac7
- https://git.kernel.org/stable/c/2bde4aca56db9fe25405d39ddb062531493a65db
- https://git.kernel.org/stable/c/50cb95487c265187289810addec5093d4fed8329
Get alerted when CVE-2021-47442 or the next vulnerability affects your stack