What’s Vulnerable › Vulnerabilities
CVE-2021-47485: IB/qib: Protect from buffer overflow in struct qib_user_sdma_pkt fields
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-22 · updated 2026-08-04
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: IB/qib: Protect from buffer overflow in struct qib_user_sdma_pkt fields Overflowing either addrlimit or bytes_togo can allow userspace to trigger a buffer overflow of kernel memory. Check for overflows in all the places doing math on user controlled buffers.
Affected products
- Linux kernel: from 2.6.35 before 4.4.292; from 4.5 before 4.9.290; from 4.10 before 4.14.255; from 4.15 before 4.19.216; from 4.20 before 5.4.157; from 5.5 before 5.10.77 — fixed in 4.14.255, 4.19.216, 4.4.292, 4.9.290, 5.10.77, 5.14.16
How to fix
Upgrade to a fixed version: Linux kernel 4.14.255, 4.19.216, 4.4.292, 4.9.290. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0d4395477741608d123dad51def9fe50b7ebe952
- https://git.kernel.org/stable/c/0f8cdfff06829a0b0348b6debc29ff6a61967724
- https://git.kernel.org/stable/c/3f57c3f67fd93b4da86aeffea1ca32c484d054ad
- https://git.kernel.org/stable/c/60833707b968d5ae02a75edb7886dcd4a957cf0d
- https://git.kernel.org/stable/c/73d2892148aa4397a885b4f4afcfc5b27a325c42
- https://git.kernel.org/stable/c/bda41654b6e0c125a624ca35d6d20beb8015b5d0
- https://git.kernel.org/stable/c/c3e17e58f571f34c51aeb17274ed02c2ed5cf780
- https://git.kernel.org/stable/c/d39bf40e55e666b5905fdbd46a0dced030ce87be
- https://git.kernel.org/stable/c/0d4395477741608d123dad51def9fe50b7ebe952
- https://git.kernel.org/stable/c/0f8cdfff06829a0b0348b6debc29ff6a61967724
- https://git.kernel.org/stable/c/3f57c3f67fd93b4da86aeffea1ca32c484d054ad
- https://git.kernel.org/stable/c/60833707b968d5ae02a75edb7886dcd4a957cf0d
Get alerted when CVE-2021-47485 or the next vulnerability affects your stack