What’s Vulnerable › Vulnerabilities
CVE-2021-47509: ALSA: pcm: oss: Limit the period size to 16MB
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-24 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: ALSA: pcm: oss: Limit the period size to 16MB Set the practical limit to the period size (the fragment shift in OSS) instead of a full 31bit; a too large value could lead to the exhaust of memory as we allocate temporary buffers of the period size, too. As of this patch, we set to 16MB limit, which should cover all use cases.
Affected products
- Linux kernel: before 4.4.295; from 4.5 before 4.9.293; from 4.10 before 4.14.258; from 4.15 before 4.19.221; from 4.20 before 5.4.165; from 5.5 before 5.10.85 — fixed in 4.14.258, 4.19.221, 4.4.295, 4.9.293, 5.10.85, 5.15.8
How to fix
Upgrade to a fixed version: Linux kernel 4.14.258, 4.19.221, 4.4.295, 4.9.293. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2e54cf6794bf82a54aaefc78da13819aea9cd28a
- https://git.kernel.org/stable/c/35a3e511032146941085f87dd9fb5b82ea5c00a2
- https://git.kernel.org/stable/c/76f19e4cbb548e28547f8c328aa0bfb3a10222d3
- https://git.kernel.org/stable/c/8839c8c0f77ab8fc0463f4ab8b37fca3f70677c2
- https://git.kernel.org/stable/c/ad45babf7886e7a212ee1d5eda9ef49f696db43c
- https://git.kernel.org/stable/c/b02a41eebcc36d4f07196780f2e165ca2c499257
- https://git.kernel.org/stable/c/be55f306396cd62c6889286a7194fd8b53363aeb
- https://git.kernel.org/stable/c/d1bb703ad050de9095f10b2d3416c32921ac6bcc
- https://git.kernel.org/stable/c/2e54cf6794bf82a54aaefc78da13819aea9cd28a
- https://git.kernel.org/stable/c/35a3e511032146941085f87dd9fb5b82ea5c00a2
- https://git.kernel.org/stable/c/76f19e4cbb548e28547f8c328aa0bfb3a10222d3
- https://git.kernel.org/stable/c/8839c8c0f77ab8fc0463f4ab8b37fca3f70677c2
Get alerted when CVE-2021-47509 or the next vulnerability affects your stack