What’s Vulnerable › Vulnerabilities
CVE-2021-47511: ALSA: pcm: oss: Fix negative period/buffer sizes
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-24 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: ALSA: pcm: oss: Fix negative period/buffer sizes The period size calculation in OSS layer may receive a negative value as an error, but the code there assumes only the positive values and handle them with size_t. Due to that, a too big value may be passed to the lower layers. This patch changes the code to handle with ssize_t and adds the proper error checks appropriately.
Affected products
- Linux kernel: before 4.4.295; from 4.5 before 4.9.293; from 4.10 before 4.14.258; from 4.15 before 4.19.221; from 4.20 before 5.4.165; from 5.5 before 5.10.85 — fixed in 4.14.258, 4.19.221, 4.4.295, 4.9.293, 5.10.85, 5.15.8
How to fix
Upgrade to a fixed version: Linux kernel 4.14.258, 4.19.221, 4.4.295, 4.9.293. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/00a860678098fcd9fa8db2b5fb9d2ddf4776d4cc
- https://git.kernel.org/stable/c/02b2b691b77cd7b951fa7b6c9d44d4e472cdc823
- https://git.kernel.org/stable/c/502e1146873d870f87da3b8f93d6bf2de5f38d0c
- https://git.kernel.org/stable/c/8af815ab052eaf74addbbfb556d63ce2137c0e1b
- https://git.kernel.org/stable/c/9d2479c960875ca1239bcb899f386970c13d9cfe
- https://git.kernel.org/stable/c/be8869d388593e57223ad39297c8e54be632f2f2
- https://git.kernel.org/stable/c/f12c8a7515f641885677960af450082569a87243
- https://git.kernel.org/stable/c/f96c0959c1ee92adc911c10d6ec209af50105049
- https://git.kernel.org/stable/c/00a860678098fcd9fa8db2b5fb9d2ddf4776d4cc
- https://git.kernel.org/stable/c/02b2b691b77cd7b951fa7b6c9d44d4e472cdc823
- https://git.kernel.org/stable/c/502e1146873d870f87da3b8f93d6bf2de5f38d0c
- https://git.kernel.org/stable/c/8af815ab052eaf74addbbfb556d63ce2137c0e1b
Get alerted when CVE-2021-47511 or the next vulnerability affects your stack