What’s Vulnerable › Vulnerabilities
CVE-2021-47605: vduse: fix memory corruption in vduse_dev_ioctl()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-19 · updated 2026-08-04
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: vduse: fix memory corruption in vduse_dev_ioctl() The "config.offset" comes from the user. There needs to a check to prevent it being out of bounds. The "config.offset" and "dev->config_size" variables are both type u32. So if the offset if out of bounds then the "dev->config_size - config.offset" subtraction results in a very high u32 value. The out of bounds offset can result in memory corruption.
Affected products
- Linux kernel: from 5.15 before 5.15.11; 5.16-rc1, 5.16-rc2, 5.16-rc3, 5.16-rc4, 5.16-rc5 — fixed in 5.15.11
How to fix
Upgrade to a fixed version: Linux kernel 5.15.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/e6c67560b4341914bec32ec536e931c22062af65
- https://git.kernel.org/stable/c/ff9f9c6e74848170fcb45c8403c80d661484c8c9
- https://git.kernel.org/stable/c/e6c67560b4341914bec32ec536e931c22062af65
- https://git.kernel.org/stable/c/ff9f9c6e74848170fcb45c8403c80d661484c8c9
Get alerted when CVE-2021-47605 or the next vulnerability affects your stack