What’s Vulnerable › Vulnerabilities
CVE-2021-47609: firmware: arm_scpi: Fix string overflow in SCPI genpd driver
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-19 · updated 2026-06-17
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: firmware: arm_scpi: Fix string overflow in SCPI genpd driver Without the bound checks for scpi_pd->name, it could result in the buffer overflow when copying the SCPI device name from the corresponding device tree node as the name string is set at maximum size of 30. Let us fix it by using devm_kasprintf so that the string buffer is allocated dynamically.
Affected products
- Linux kernel: from 4.8 before 4.9.294; from 4.10 before 4.14.259; from 4.15 before 4.19.222; from 4.20 before 5.4.168; from 5.5 before 5.10.88; from 5.11 before 5.15.11 — fixed in 4.14.259, 4.19.222, 4.9.294, 5.10.88, 5.15.11, 5.4.168
How to fix
Upgrade to a fixed version: Linux kernel 4.14.259, 4.19.222, 4.9.294, 5.10.88. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4694b1ec425a2d20d6f8ca3db594829fdf5f2672
- https://git.kernel.org/stable/c/639901b9429a3195e0fead981ed74b51f5f31538
- https://git.kernel.org/stable/c/7e8645ca2c0046f7cd2f0f7d569fc036c8abaedb
- https://git.kernel.org/stable/c/802a1a8501563714a5fe8824f4ed27fec04a0719
- https://git.kernel.org/stable/c/865ed67ab955428b9aa771d8b4f1e4fb7fd08945
- https://git.kernel.org/stable/c/976389cbb16cee46847e5d06250a3a0b5506781e
- https://git.kernel.org/stable/c/f0f484714f35d24ffa0ecb4afe3df1c5b225411d
- https://git.kernel.org/stable/c/4694b1ec425a2d20d6f8ca3db594829fdf5f2672
- https://git.kernel.org/stable/c/639901b9429a3195e0fead981ed74b51f5f31538
- https://git.kernel.org/stable/c/7e8645ca2c0046f7cd2f0f7d569fc036c8abaedb
- https://git.kernel.org/stable/c/802a1a8501563714a5fe8824f4ed27fec04a0719
- https://git.kernel.org/stable/c/865ed67ab955428b9aa771d8b4f1e4fb7fd08945
Get alerted when CVE-2021-47609 or the next vulnerability affects your stack