What’s Vulnerable › Vulnerabilities
CVE-2021-47611: mac80211: validate extended element ID is present
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-19 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: mac80211: validate extended element ID is present Before attempting to parse an extended element, verify that the extended element ID is present.
Affected products
- Linux kernel: from 4.19 before 4.19.222; from 4.20 before 5.4.168; from 5.5 before 5.10.88; from 5.11 before 5.15.11; 5.16-rc1, 5.16-rc2, 5.16-rc3, 5.16-rc4, 5.16-rc5 — fixed in 4.19.222, 5.10.88, 5.15.11, 5.4.168
How to fix
Upgrade to a fixed version: Linux kernel 4.19.222, 5.10.88, 5.15.11, 5.4.168. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/03029bb044ccee60adbc93e70713f3ae58abc3a1
- https://git.kernel.org/stable/c/768c0b19b50665e337c96858aa2b7928d6dcf756
- https://git.kernel.org/stable/c/7fd214fc7f2ee3a89f91e717e3cfad55f5a27045
- https://git.kernel.org/stable/c/a19cf6844b509d44ecbd536f33d314d91ecdd2b5
- https://git.kernel.org/stable/c/c62b16f98688ae7bc0ab23a6490481f4ce9b3a49
- https://git.kernel.org/stable/c/03029bb044ccee60adbc93e70713f3ae58abc3a1
- https://git.kernel.org/stable/c/768c0b19b50665e337c96858aa2b7928d6dcf756
- https://git.kernel.org/stable/c/7fd214fc7f2ee3a89f91e717e3cfad55f5a27045
- https://git.kernel.org/stable/c/a19cf6844b509d44ecbd536f33d314d91ecdd2b5
- https://git.kernel.org/stable/c/c62b16f98688ae7bc0ab23a6490481f4ce9b3a49
Get alerted when CVE-2021-47611 or the next vulnerability affects your stack