What’s Vulnerable › Vulnerabilities
CVE-2021-47688
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-23 · updated 2026-06-17
- Weakness: CWE-696
Description
In WhiteBeam 0.2.0 through 0.2.1 before 0.2.2, a user with local access to a server can bypass the allow-list functionality because a file can be truncated in the OpenFileDescriptor action before the VerifyCanWrite action is performed.
Affected products
- WhiteBeam: from 0.2.0 before 0.2.2 — fixed in 0.2.2
How to fix
Upgrade to a fixed version: WhiteBeam 0.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/WhiteBeamSec/WhiteBeam/pull/22
- https://github.com/WhiteBeamSec/WhiteBeam/security/advisories/GHSA-3f8r-9483-pfxj
- https://github.com/WhiteBeamSec/WhiteBeam/security/policy
Get alerted when CVE-2021-47688 or the next vulnerability affects your stack