What’s Vulnerable › Vulnerabilities
CVE-2021-47811: Grocery crud 1.6.4 - 'order_by' SQL Injection
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-16 · updated 2026-06-17
- Weakness: CWE-89
Description
Grocery Crud 1.6.4 contains a SQL injection vulnerability in the order_by parameter that allows remote attackers to manipulate database queries. Attackers can inject malicious SQL code through the order_by[] parameter in POST requests to the ajax_list endpoint to potentially extract or modify database information.
Affected products
- Grocerycrud Grocery crud: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: Grocerycrud Grocery crud 2.0.1. Check the vendor advisory for mitigations.
References
- https://www.exploit-db.com/exploits/49985
- https://www.grocerycrud.com/
- https://www.grocerycrud.com/downloads
- https://www.vulncheck.com/advisories/grocery-crud-orderby-sql-injection
- https://www.exploit-db.com/exploits/49985
Get alerted when CVE-2021-47811 or the next vulnerability affects your stack