What’s Vulnerable › Vulnerabilities
CVE-2021-47815: Nsauditor 3.2.3 - Denial of Service (PoC)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-16 · updated 2026-06-17
- Weakness: CWE-120
Description
Nsauditor 3.2.3 contains a denial of service vulnerability in the registration code input field that allows attackers to crash the application. Attackers can paste a large buffer of 256 repeated characters into the 'Key' field to trigger an application crash.
Affected products
- Nsauditor: before 3.2.7 — fixed in 3.2.7
How to fix
Upgrade to a fixed version: Nsauditor 3.2.7. Check the vendor advisory for mitigations.
References
- http://www.nsauditor.com
- https://www.exploit-db.com/exploits/49965
- https://www.vulncheck.com/advisories/nsauditor-denial-of-service-poc
Get alerted when CVE-2021-47815 or the next vulnerability affects your stack